Openrowset Error Messages in sql server

Published: 24 February 2013
on channel: TheSSScreations
6,577
16

Hi,

In this video we will discuss the following error message which occurs when we are trying to use "OPENROWSET" or "OPENDATASOURCE".

Error Message:
----------------------
SQL Server blocked access to STATEMENT 'OpenRowset/OpenDatasource' of component 'Ad Hoc Distributed Queries'

because this component is turned off as part of the security configuration for this server. A system

administrator can enable the use of 'Ad Hoc Distributed Queries' by using sp_configure. For more information

about enabling 'Ad Hoc Distributed Queries', see "Surface Area Configuration" in SQL Server Books Online.


We can resolve this error message by using sp_configure. Run the below commands in sql server to resolve the above openrowset error:


sp_configure 'show advanced options', 1
RECONFIGURE
sp_configure 'Ad Hoc Distributed Queries', 1
RECONFIGURE


On this page of the site you can watch the video online Openrowset Error Messages in sql server with a duration of hours minute second in good quality, which was uploaded by the user TheSSScreations 24 February 2013, share the link with friends and acquaintances, this video has already been watched 6,577 times on youtube and it was liked by 16 viewers. Enjoy your viewing!